Tu servidor está ejecutando la versión 5.1.6 de PHP, pero WordPess 3.9.1 necesita, al menos, la versión 5.2.4.